Get email notifications whenever Tiger Institute System Status creates, updates or resolves an incident.
Get text message notifications whenever Tiger Institute System Status creates or resolves an incident.
Get webhook notifications whenever Tiger Institute System Status creates an incident, updates an incident, resolves an incident or changes a component status.
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 10, 2026 - 21:00 CDT
Scheduled
S Situation ________________________________________________________________________________ Navex PolicyTech will undergo planned vendor maintenance tonight, Wednesday, June 10, 2026, from 2100 to 0100 on Thursday, June 11, 2026. No downtime is expected; however, users may experience temporary performance impacts during the maintenance window.
B Background _________________________________________________________________________________ Navex PolicyTech is the application used to review, update, and access all MU Health Care policies.
A Assessment __________________________________________________________________________________ The Navex PolicyTech vendor will perform planned maintenance from 2100 on Wednesday, June 10, 2026, through 0100 on Thursday, June 11, 2026. Although no system downtime is anticipated, users may experience the following during the maintenance window: • Slower-than-normal system performance, with response times of up to 30 seconds. • The need to log in again during their session. • The need to refresh or reload web pages to access updates implemented during the maintenance.
R Recommendation ___________________________________________________________________________________ Please share this information with your teams so they are aware of the planned maintenance and potential impacts.
If you experience issues during or after the maintenance window, please contact the Hospital Help Desk at 573-884-4357.
Posted Jun 10, 2026 - 10:57 CDT
This scheduled maintenance affected: Other Tiger Institute IT solution.