Tiger Institute for Health Innovation
Tiger Institute System Status

Unplanned: Millennium Cloud Applications Experiencing Performance Issues

Incident Report for Tiger Institute System Status

Resolved

Millennium Cloud applications should now be accessible. Users may need to log out to see improved performance. Please notify Help Desk if further issues occur.
Posted Oct 14, 2025 - 13:16 CDT

Investigating

S Situation

Oracle has identified a potential issue that may be impacting some Millennium Cloud Services applications. Users may be experiencing possible slowness and performance degradation in the following Oracle Health EHR functionality: Smart Zone alerts, Workspace (right-side of workflow view), Media Gallery, Problem List, and Care Team Assignments. Additional applications may be impacted as well.
________________________________________________________________________________


B Background

Cloud-based functions are managed separately than base EMR functions and CAA.
_________________________________________________________________________________


A Assessment

Oracle teams are engaged and will provide further updates as they become available.
__________________________________________________________________________________


R Recommendation

Please use alternative EHR to complete documentation and tasks.
__________________________________________________________________________________



Please communicate this to staff.
Posted Oct 14, 2025 - 11:45 CDT
This incident affected: Cerner applications (PowerChart, RevCycle, FirstNet, SurgiNet, Cerner Retail Pharmacy, RXStation, etc).