Tiger Institute for Health Innovation
Tiger Institute System Status

Cardiology Echocardiogram Intermittent PACS Outage

Incident Report for Tiger Institute System Status

Monitoring

All patients should have all expected echo data and images loaded into cardiology PACS. Please check when you have time and call the Help Desk if you are still seeing missing images.
Posted Apr 23, 2026 - 16:37 CDT

Investigating

S - Situation

Cardiology Echocardiograms are intermittently not crossing from some US machines to Change HealthCare Cardiology PACS.



B - Background

Starting the morning of April 22, 2026, the Cardiology department noticed that echocardiograms are intermittently not crossing Change HealthCare Cardiology PACS



A - Assessment

Change Health Care (vendor) is troubleshooting the issue and working to process the backlog of images. We are still experiencing some dropped images this morning, as well. To date, no ETA on issue resolution


R - Recommendation

We are asking user to keep a list of patients/FIN who have images listed as 'NA'. Once you have a list, place a ticket to the Help Desk (573-884-4357) and ask it to be routed to the local Cardiology team. We will work with the Change Healthcare (vendor) to ensure these images flow over once they have resolved the issue.
Posted Apr 23, 2026 - 10:58 CDT
This incident affects: PACS.