Tiger Institute for Health Innovation
Tiger Institute System Status

Unplanned CRMC Only Limited Access to EMR Applications

Incident Report for Tiger Institute System Status

Identified

The incident investigation is ongoing and we will continue to await confirmation from our carrier vendors that full resolution is in place and root cause analysis has been initiated. However, CRMC users have been able to access Millennium applications using their normal workflows for about two hours.

Should any change in status for CRMC users' access to Millennium applications and they are not able to access these applications has normal, please report the issue to the Help Desk and utilize the step-by step instructions to access the MUHC Virtual Desktop (link below) to access Millennium applications.

https://ced.muhealth.org/sites/ced/files/2026-09/Guide for EMR Access during CRMC network outage 9.22.26.pdf
Posted Sep 22, 2026 - 08:30 CDT

Update

CRMC users onsite have reported the ability to access Millennium applications through normal workflows. The incident investigation is ongoing and we await confirmation from our carrier vendors on resolution. Updates will continue to be provided as they become available.
Posted Sep 22, 2026 - 06:44 CDT

Update

As a workaround, CRMC users can browse to https://iportal.umh.edu and login with your MU credentials. Once logged in, click the desktops tab at the top of the page and select Win11 VDI. You can also click in the search box and search for "Win11". Once the Virtual desktop loads, you can launch PowerChart/FirstNet from Citrix Workspace. Instructions with images can be accessed here:

https://ced.muhealth.org/sites/ced/files/2026-09/Guide%20for%20EMR%20Access%20during%20CRMC%20network%20outage%209.22.26.pdf

If you receive an error message with this process, please call the help desk at 573-884-4357 (HELP).
Posted Sep 22, 2026 - 05:26 CDT

Update

We are continuing to investigate the issue. More updates will be provided as they are available.
Posted Sep 22, 2026 - 05:03 CDT

Investigating

S Situation

Oracle Health has reported specific network outages across multiple clients.
________________________________________________________________________________


B Background

CRMC and UH have different network paths of accessing MUHC EMR applications.
_________________________________________________________________________________


A Assessment

Oracle Health notified onsite Tiger Institute leadership 9/22/26 at 0145 that there were multiple network outages across multiple client sites, and due to two separate network outage situations all of CRMC's network paths to access the EMR were impacted and CRMC users currently are unable to access the EMR.
__________________________________________________________________________________


R Recommendation

Proceed to your Department's EMR Downtime Procedures until network access is restored. Downtime procedures are available for reference in Navex.
Notification will be provided with further updates and status of this outage and ability access the EMR for CRMC users.
__________________________________________________________________________________



Please communicate this to staff.
Posted Sep 22, 2026 - 02:29 CDT
This incident affects: Cerner applications (PowerChart, RevCycle, FirstNet, SurgiNet, etc).