Tiger Institute for Health Innovation
Tiger Institute System Status

System Slowness

Incident Report for Tiger Institute System Status

Update

We are continuing to investigate this issue.
Posted Feb 18, 2026 - 09:50 CST

Investigating

S Situation
Users are reporting slowness across Cerner applications; including but not limited to MPages, Discern Synchronous and Provenance/External Records.
________________________________________________________________________________
B Background
We are actively investigating.
_________________________________________________________________________________
A Assessment
Users have been reporting continued impact to EHR experience.
__________________________________________________________________________________
R Recommendation
As troubleshooting progresses updates will be provided.
__________________________________________________________________________________
Please communicate this change to staff.
Posted Feb 18, 2026 - 09:48 CST
This incident affects: Cerner applications (PowerChart, RevCycle, FirstNet, SurgiNet, etc).