Tiger Institute for Health Innovation
Tiger Institute System Status

Revenue Cycle Cancelation Option Issue

Incident Report for Tiger Institute System Status

Resolved

This issue has been resolved.
Posted Feb 17, 2026 - 09:28 CST

Investigating

S Situation

Users are unable to select options in the drop down menu when attempting to schedule or modify a patient appointment. This is also impacting the cancel reason in the portal.
________________________________________________________________________________


B Background

This cancelation option drop down is part of the appointment cancelation/modification workflow.
_________________________________________________________________________________


A Assessment

All resources are engaged and investigating.
__________________________________________________________________________________


R Recommendation

Please share this information with your staff.
Posted Feb 17, 2026 - 09:13 CST
This incident affected: Cerner applications (PowerChart, RevCycle, FirstNet, SurgiNet, etc).