Tiger Institute for Health Innovation
Tiger Institute System Status

University Campus -- Cisco Finesse Issues

Incident Report for Tiger Institute System Status

Resolved

A fix has been implemented. If issues still persist, please call the University of Missouri Campus Help Desk at 573-882-5000.
Posted Mar 01, 2026 - 11:56 CST

Investigating

Cisco Finesse problem
New incident: Investigating
Several people have reported that Cisco Finesse is having issues at the MU Hospital. Techs are looking into the problem now.
Continue to check University Campus Status Pages for updates.
Posted Mar 01, 2026 - 10:17 CST
This incident affected: Network/Phone Services.