Tiger Institute for Health Innovation
Tiger Institute System Status
Microsoft Teams Issues
Incident Report for Tiger Institute System Status
Resolved
This incident has been resolved.
Posted Apr 30, 2024 - 11:44 CDT
Investigating
We are currently investigating an issue with Microsoft Teams causing reduced speeds for users or not allowing users to login to Teams intermittingly. We are continuing to investigate this issues and will provide updates as they become available.
Posted Apr 24, 2024 - 09:18 CDT
This incident affected: Microsoft Office Apps.