Tiger Institute for Health Innovation
Tiger Institute System Status

Multiple users experiencing issues logging in UKG, TigerConnect , PowerBI and MFA.

Incident Report for Tiger Institute System Status

Resolved

Please refer to PowerBI SBAR for stale data updates. Issues logging into UKG, TigerConnect, PowerBI and MFA have been resolved.
Posted Feb 24, 2026 - 09:43 CST

Update

We are continuing to monitor for any further issues.
Posted Feb 24, 2026 - 09:40 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 24, 2026 - 09:38 CST

Investigating

We are currently investigating this issue.
Posted Feb 24, 2026 - 07:37 CST
This incident affected: Paging/TigerConnect, Network/Phone Services, Active Directory, and Other Tiger Institute IT solution.