Tiger Institute for Health Innovation
Tiger Institute System Status

Cable TV Outage MUHC Wide

Incident Report for Tiger Institute System Status

Resolved

This incident has been resolved.
Posted May 20, 2026 - 16:09 CDT

Identified

Latest Update From Spectrum:
The Spectrum Business NOC has We identified a possible fiber cut in your area. We’re in the process of assessing and isolating the issue. While the median repair time in Missouri is 8 hour(s), we’ll be able to share a more specific timeline once we finish our assessment. We’ll send hourly updates, or sooner than that if conditions change.
Posted May 20, 2026 - 14:03 CDT

Investigating

S Situation

Campus and hospital are impacted by cable television outage.
________________________________________________________________________________


B Background

Impact was noticed roughly 30 minutes ago.
_________________________________________________________________________________


A Assessment

Campus is investigating the cause.
__________________________________________________________________________________


R Recommendation

Please wait for more updates from the technicians investigating.
__________________________________________________________________________________



Please communicate this to staff.
Posted May 20, 2026 - 11:10 CDT
This incident affected: Other Tiger Institute IT solution.