Tiger Institute for Health Innovation
Tiger Institute System Status

Teletracking Outage

Incident Report for Tiger Institute System Status

Resolved

The incident has been resolved. If any issues return, please submit a ticket with the help desk.
Posted Mar 29, 2026 - 18:44 CDT

Monitoring

A fix has been implemented and Teletracking is monitoring the results. Please put in a help desk ticket (573-884-4357) if you are continuing to see issues in Teletracking.
Posted Mar 29, 2026 - 11:18 CDT

Investigating

Teletracking is currently having an issue with application views that aid in patient movement, admissions/discharges, and environmental services needs. This is an impacting all clients and Teletracking resources are engaged and working on the issue with no ETA. Please use TigerConnect to reach out to Transport and Environmental Services until Teletracking issues have been resolved. Please Call Logistic Center for any patient Admissions, Transfers, and notifications of discharges to aid in bed placement.
Posted Mar 29, 2026 - 07:21 CDT
This incident affected: Teletracking.