Tiger Institute for Health Innovation
Tiger Institute System Status

Rev Cycle Eligibility - Connection to Missouri Medicaid experiencing processing delays or interruptions - 03/17/2026

Incident Report for Tiger Institute System Status

Investigating

S Situation
________________________________________________________________________________
Rev Cycle Eligibility is operational however it has been identified that Medicaid Missouri is processing slower than normal or is experiencing an interruption for real-time eligibility transactions.

B Background
_________________________________________________________________________________
Medicaid of Missouri is processing eligibility requests slower than normal or is experiencing an interruption for real-time eligibility transactions.

A Assessment
__________________________________________________________________________________
Technical teams have been engaged.

R Recommendation
__________________________________________________________________________________
Updates will be sent as additional information is received.
Posted Mar 17, 2026 - 08:30 CDT
This incident affects: Cerner applications (PowerChart, RevCycle, FirstNet, SurgiNet, etc).