Tiger Institute for Health Innovation
Tiger Institute System Status

MU Campus Phone Outage

Incident Report for Tiger Institute System Status

Resolved

This incident has been resolved.
Posted Jul 15, 2026 - 14:09 CDT

Investigating

S Situation
________________________________________________________________________________
MU Health Care is currently experiencing a phone system outage affecting inbound and outbound calls across the organization.
B Background
_________________________________________________________________________________
The outage is impacting the ability for patients, visitors, and staff to communicate with clinics, departments, and other MU Health Care services by phone. Technical teams are actively investigating the issue and working to restore service as quickly as possible.

A Assessment
__________________________________________________________________________________
Phone communications may be delayed or unavailable until the outage is resolved. This may impact patient access and routine operations. There is currently no estimated time for full service restoration.
R Recommendation
___________________________________________________________________________________
Please use alternate communication methods when available and appropriate. Continue to monitor for updates as they are provided. We appreciate your patience while our teams work to restore normal phone service.
Any issues following this work, please report to the help desk.

Please communicate this issue to staff.
Posted Jul 15, 2026 - 13:44 CDT