Tiger Institute for Health Innovation
Tiger Institute System Status

Experian Alert - Coverage Discovery processing delays 4/10/26

Incident Report for Tiger Institute System Status

Resolved

This incident has been resolved.
Posted Apr 10, 2026 - 11:18 CDT

Investigating

S Situation
________________________________________________________________________________
You may be experiencing processing delays when using Coverage Discovery.

B Background
_________________________________________________________________________________
Users are experiencing delays in processing for Experian Coverage Discovery.

A Assessment
__________________________________________________________________________________
Status (9:00 a.m. CT): Technical teams are investigating.

R Recommendation
__________________________________________________________________________________
Updates will be sent out as additional information is received.

Please communicate this to staff.
Posted Apr 10, 2026 - 09:11 CDT
This incident affected: Cerner applications (PowerChart, RevCycle, FirstNet, SurgiNet, etc).