Tiger Institute for Health Innovation
Tiger Institute System Status

Cerner Rev Cycle - Credit Card Machine Error

Incident Report for Tiger Institute System Status

Resolved

This issue has been resolved.
Posted Oct 21, 2025 - 08:18 CDT

Investigating

S Situation

Bank of America has identified an issue impacting credit card devices.
________________________________________________________________________________


B Background

Users are getting this message on their device - "Terminal is unavailable because the local network is unreachable please check your wi-fi ethernet settings" If this error displays, users cannot accept credit card payment.

_________________________________________________________________________________


A Assessment

Bank of America resources are engaged.
__________________________________________________________________________________


R Recommendation

Users should ask for cash or check payment.
__________________________________________________________________________________



Please communicate this to staff.
Posted Oct 20, 2025 - 12:35 CDT
This incident affected: Cerner applications (PowerChart, RevCycle, FirstNet, SurgiNet, Cerner Retail Pharmacy, RXStation, etc).