Tiger Institute for Health Innovation
Tiger Institute System Status

Glucometer results not flowing into PowerChart

Incident Report for Tiger Institute System Status

Resolved

IT has identified the root cause and has implemented a fix. Results should now be flowing from the Glucometers to PowerChart. If any other issues occur, please contact the Helpdesk at 573-884-HELP.
Posted Mar 23, 2026 - 10:44 CDT

Investigating

S Situation

Glucometer results are not flowing into PowerChart
________________________________________________________________________________


B Background

Glucometer results began failing to transfer into PowerChart last night, occurring just after midnight on Monday March 23rd.
_________________________________________________________________________________


A Assessment

IT is currently investigating this issue and will provide updates as they are made available.
__________________________________________________________________________________


R Recommendation

Please follow downtime procedures at this time.
__________________________________________________________________________________



Please communicate this to staff.
Posted Mar 23, 2026 - 10:20 CDT
This incident affected: Cerner applications (PowerChart, RevCycle, FirstNet, SurgiNet, etc).