Tiger Institute for Health Innovation
Tiger Institute System Status

Fuji Pacs at CRMC Upgrade Issue

Incident Report for Tiger Institute System Status

Update

Currently PACS system is up and running. Link in Powerchart is not working, but can be accessed via CRMC Citrix or locally installed on CRMC devices.
Posted Nov 18, 2024 - 12:39 CST

Identified

Installers are being pushed out to computers. Please call help desk if you need urgent install of PACS. For scanning issues please let Help Desk know to place a ticket for Anc Apps Radiology to install. Current state is operational, but working through some minor issues at the moment
Posted Oct 16, 2024 - 10:51 CDT

Investigating

S Situation

Fuji PACS is experiencing access issues after the upgrade.
________________________________________________________________________________


B Background

Fuji PACS is the imaging system at CRMC for Radiology.
_________________________________________________________________________________


A Assessment

The onsite team is working to manually install a fix on each workstation running Fuji PACS. In parallel, IT is working on getting a file from Fuji that will allow for fix to be pushed to each workstation remotely.
__________________________________________________________________________________


R Recommendation

Please use downtime procedures until the onsite team can get each workstation upgraded.
__________________________________________________________________________________



Please communicate this to staff.
Posted Oct 15, 2024 - 10:24 CDT
This incident affects: PACS.