Tiger Institute for Health Innovation
Tiger Institute System Status

Experian - Mulitple Product Delays 10/20/25

Incident Report for Tiger Institute System Status

Resolved

This issue has been resolved.
Posted Oct 21, 2025 - 08:59 CDT

Investigating

S Situation
________________________________________________________________________________
You may be experiencing intermittent processing delays when using the following products through eCare NEXT:
• Eligibility Verification
• Identity Verification
• Patient Estimates
• Patient Financial Clearance
• Authorizations
• Notice of Care (Notice of Admission)
• Enhanced Claim Status
• Claim Status
• Coverage Discovery
• PaymentSafe
• Registration Quality Assurance
• Medical Necessity
• Registration Accelerator
• Patient Financial Advisor
Power Reporting
Power Data




B Background
_________________________________________________________________________________
Users are receiving processing delays via multiple products through eCare NEXT.

A Assessment
__________________________________________________________________________________
Experian engineers are currently engaged.

R Recommendation
__________________________________________________________________________________
Updates will be sent out as additional information is received.

Please communicate this to staff.
Posted Oct 20, 2025 - 09:35 CDT
This incident affected: Cerner applications (PowerChart, RevCycle, FirstNet, SurgiNet, Cerner Retail Pharmacy, RXStation, etc).