Tiger Institute for Health Innovation
Tiger Institute System Status

Rev Cycle Eligibility - Experiencing processing delays or interruptions - 03/16/2026

Incident Report for Tiger Institute System Status

Update

Rev Cycle Eligibility is now experiencing slower processing than normal or is experiencing an interruption for real-time eligibility transactions for all payers. Users may have to check eligibility via payer websites until this issue is resolved.
Posted Mar 16, 2026 - 13:37 CDT

Update

We are continuing to investigate this issue.
Posted Mar 16, 2026 - 13:37 CDT

Investigating

S Situation
________________________________________________________________________________
Rev Cycle Eligibility is now experiencing slower processing than normal or is experiencing an interruption for real-time eligibility transactions for all payers.

B Background
_________________________________________________________________________________
Users are unable to process eligibility transactions

A Assessment
__________________________________________________________________________________
Technical teams have been engaged.

R Recommendation
__________________________________________________________________________________
Updates will be sent as additional information is received. Users may have to check eligibility via payer websites until this issue is resolved.

Please communicate this to staff.
Posted Mar 16, 2026 - 13:10 CDT
This incident affects: Cerner applications (PowerChart, RevCycle, FirstNet, SurgiNet, etc).